9,185 Photos

X-Pro II Andrew Stonebreaker
  •   adamdeloza Haha you redoing sups. ? You down for pismo dune trip end of this month or next possibly got bunch of my buddy's going all 450s 4d
  •   astone_203 I need to figure out my spark issue and get my sups sent off. @adamdeloza 4d
  •   adamdeloza Check rev box in front unplug spray wd 40 in connection plug it in try it 4d
  •   astone_203 I have power to coil but nothing out. So pretty sure it's coil. @adamdeloza 4d
  •   adamdeloza 0h gotcha have seen if the plug on the wire you kno how they unscrew prob corroded just from when you wash the the bike 4d
  •   adamdeloza But anyway when your done lemme so if you wana plan a trip can know how big reservation to get 4d
  •   astone_203 All connections are fine. Plug going into coil is good and clean, ground is good, power in, but nothing out booth and wire are good, test at the coil, nothing. @adamdeloza 4d
  •   astone_203 For sure. First trip will prob be Halloween at glamis. @adamdeloza 4d

» LOG IN to write comment.

» LOG IN to write comment.

eal1995 Sneak peak #datstretchdoe 1w

» LOG IN to write comment.

Earlybird Hernan Chaidez

» LOG IN to write comment.

X-Pro II Hernan Chaidez

» LOG IN to write comment.

tacoornot They see me rollin.... 2w

» LOG IN to write comment.

char__lieee Got the rear fitment on point! #hellapoke #240sx #s13 3w

» LOG IN to write comment.

» LOG IN to write comment.

sir.ek4 Chilling with the fams @tsxswagg bass finally on point @chenchowavy @tsxswagg @dee2jdm @llen.y #tsx #hellapoke #TeamDelPatio 3w

» LOG IN to write comment.